Results 1 to 2 of 2

Thread: help with is300 issues

  1. #1
    ch0nst3r
    Join Date
    Jun 2008
    Location
    duluth
    Age
    31
    Posts
    75
    Rep Power
    13

    Default help with is300 issues

    dont wanna get flamed but im stumped. recently my bank 1 sensor 1 went out. right before the check engine light turned on to notify me of that problem third, 4th and 5th gear rpm will slip at full throttle and if i keep flooring it i smell my clutch burning when im not pressing the clutch at all. anyone with info?

  2. #2
    IA's Custom PC Junky eViLMunkey's Avatar
    Join Date
    Nov 2002
    Location
    Acworth, Georgia, United States
    Age
    39
    Posts
    9,578
    Rep Power
    29

    Default

    well your clutch issue has nothing to do w/ your O2 and how would you know it was going out w/ out you PCM notifying you?


    more than likely you need a new clutch or to drop and see if there is scoring on it. .



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
ImportAtlanta is a community of gearheads and car enthusiasts. It does not matter what kind of car or bike you drive, IA is an open community for any gearhead. Whether you're looking for advice on a performance build or posting your wheels for sale, you're welcome here!
Announcement
Welcome back to ImportAtlanta. We are currently undergoing many changes, so please report any issues you encounter with the site using the 'Contact Us' button below. Thank you!