PDA

View Full Version : 97 528i Overheating



rahman20k
02-21-2012, 05:01 PM
Hey guys my 528i is overheating. Upper hose will be hot but lower hose is barely even warm. The temperature will rise into hot, but when i rev the engine more it goes back into normal operating mode. I constantly have to rev it at every traffic light to keep it from over heating. I replaced the thermostat today, still upper hose has pressure after revving it but lower hose does not. What could it be? Any help would be nice since this is my daily driver car. Thanks!

cody8899
02-21-2012, 05:38 PM
pretty sure you have a blown head gasket , and 5 series are known for bad head gaskets

gottraction?
02-21-2012, 06:18 PM
sounds like blown headgasket. can u find any leaks anywhere? are the fans cutting on? you can sell it to me for dirt!! lol

rahman20k
02-27-2012, 01:32 PM
Thermostat changed, bled system out. Its fine guys lol

MeFryRice
02-27-2012, 02:18 PM
Have you checked the waterpump to make sure it's still flowing? Check with AutoZone and see if they have a tool you can rent that will allow you to pressurize the cooling system. Start off from here and see where that takes you before you throw a bunch of money into parts without confirming they're the issue. You have to remember (if you was not aware already) that the majority of the cooling system is make of plastic parts which are only failure points. We service a bunch of E39 5-series and have yet to come across one with a bad headgasket.

rahman20k
03-05-2012, 10:43 PM
Have you checked the waterpump to make sure it's still flowing? Check with AutoZone and see if they have a tool you can rent that will allow you to pressurize the cooling system. Start off from here and see where that takes you before you throw a bunch of money into parts without confirming they're the issue. You have to remember (if you was not aware already) that the majority of the cooling system is make of plastic parts which are only failure points. We service a bunch of E39 5-series and have yet to come across one with a bad headgasket.


Thanks, its a bad headgasket. Cylinder 3 had water in it, so i went to Napa and got some headgasket seal for a temporary fix, now it runs fine with no overheating . Will probably just get rid of it soon

98blackcivic
03-05-2012, 11:29 PM
i had the same problem with my civic...once u rev the engine, temp needle would go down...
i remember i drove it like that for a while..i drove to macon and on that str8 highway rd, everytime i would go on top of a hill, it would climb down, and when i went down the hill, the needle would climb back up...
i eventually got it replaced...no engine damage from over heating ;)
d16y8s rule!!

rahman20k
03-10-2012, 12:16 PM
i had the same problem with my civic...once u rev the engine, temp needle would go down...
i remember i drove it like that for a while..i drove to macon and on that str8 highway rd, everytime i would go on top of a hill, it would climb down, and when i went down the hill, the needle would climb back up...
i eventually got it replaced...no engine damage from over heating ;)
d16y8s rule!!

So it was the headgasket too? Or what?