PDA

View Full Version : srt4 not hitting full boost...



0\s accord
08-03-2011, 01:00 AM
ok like the title says..... im assuming it is just a boost leak that i have to find but wanted to run it by some other ppl first.... ok high boost on my car is 19 lbs low is 10...

it hits low boost fine with no problems....

but on high boost (which is 19psi) but its only reading 10-11psi....
while at full throttle its blowing off like u just let out on the throttle....

ik my boost gauge is reading correctly (im using greddy eletronic boost controller) but ik it is reading right... my B.O.V is a greddy R\S and my waste gate is A.G.P....

im just trying to rule out anything else it could be... thanks for all the input:goodjob:

98blackcivic
08-03-2011, 01:39 AM
good luck...judging by ur name..should kept the accord..lol...but then im a honda boy..

EmminoDaGreat
08-03-2011, 02:00 AM
I just fixed one that had a locked up turbo, and sometimes the flapper door sticks on wastegate

0\s accord
08-03-2011, 02:04 PM
but if it was sticking wouldnt it stick all the way open or shut? i can still build 11psi....just not the normal 19... do u think there is a poss. of a boost leak? but than again if it was a boost leak.. i wouldnt be building much of any or non at all rite?

also could the b.o.v be bad? cause its blowing off even while im at full throttle....

EmminoDaGreat
08-03-2011, 03:29 PM
It can be a boost leak, check all vacuum lines and couplers/clamps also could be a leaky bov

0\s accord
08-03-2011, 05:36 PM
i think it might be a leaky b.o.v... its shuttering pretty well.... never done it before....

i checked every vacuum line and all were still connected good ......

CHADbee
08-03-2011, 05:50 PM
i think it might be a leaky b.o.v... its shuttering pretty well.... never done it before....

i checked every vacuum line and all were still connected good ......

Look up how to make a boost leak tester and do a test on the car. Those cars are horrible about leaks. Do that before you replace anything.

blown_ss
08-03-2011, 06:00 PM
Look up how to make a boost leak tester and do a test on the car. Those cars are horrible about leaks. Do that before you replace anything.

this all day long. i made one when i had a srt4, it saves a lot of money.

onebadgt
08-03-2011, 10:15 PM
had the exact same bov and wastegate on mine and had the same problem. thought i had a boost leak, i did and fixed it but still only saw 13lbs, then figured out the bov was not holding air as well. got it fixed, still would hit like 15 and drop to 13. ended up being that the agp wastegate sucks!!!! The spring has all kinds of trouble. replaced it and never had another issue!

0\s accord
08-03-2011, 10:37 PM
ok just made my own boost leak tester.... only found one small out by the iat.... fixed it... took it down the road still nothing.....

it still shutters bad when letting out on the throttle...also when u give it full throttle expecting to hit full boost...all u here is a loud pppppssssshhhhhhh.....(sorry only way i could describe it).

again...there are no boost leaks now.....so only thing i can think of is its the bov...or wastegate...which one would u start with.....also what are good replacements..

thanks again for all the help

onebadgt
08-03-2011, 10:49 PM
replace the greddy rs with a hks ssq, its the only one ive never had problems with. plus it sound awesome lol

0\s accord
08-04-2011, 03:19 PM
i buddy it going to give me that stock piece of piping to see if that fixes it.... than i will go from there! thanks all for your help

onebadgt
08-04-2011, 04:17 PM
no prob, always glad to help someone. i assume your talking about replacing the aftermarket uppipe and bov with the factory uppipe? if so im assuming you also have a block off plate on the factory bov. if thats the case make sure you reattach the factory bov etc or you will have no way of releasing boost pressure.

0\s accord
08-04-2011, 07:24 PM
yeah thats correct lol and i know but thanks for making sure i know haha... also on the eletronic greddy boost controller.... where the vacuum lines run into what i think is what controls the boost..there is 2 vacuum lines running into it but there is an extra spot for another that has nothing in it....could that be a problem?

0\s accord
08-04-2011, 07:33 PM
nevermind..one port is for venting.... is what a buddy of mine told me

0\s accord
08-04-2011, 07:37 PM
also i un did the vacuum line to the wastegate.....took it down the road and still wouldnt build past 11 ( i would assume it would keep building boost...)

onebadgt
08-04-2011, 09:19 PM
sounds to me like its the wastegate not being able to hold boost pat 11lbs more than anything.

0\s accord
08-04-2011, 10:04 PM
so would u start with trying a different wastegate... i cant wait tell i get the extra cash for a turbo kit

onebadgt
08-04-2011, 11:13 PM
ya, my 1st guess would be boost leaks, when you 100% sure that not it, the only issues would be either your wastegate will not hold the boost, or your bov wont. it could be either, and i have heard horror stories from both. me personally i had trouble out of the greddy rs more than the wastegate, but when you can afford to i would replace both. start off by putting the factory uppipe etc back on. if that fixes the prob you know its the bov. if not you can ref-attachyour bov and replace the wastegate

Drummerboy
08-05-2011, 11:41 AM
if it's the bov, try adding another spring. Also, try playing with the throttle rotor while you're looking under the hood. Rev it to blow off and see if anything strange happens. That's how I found out my bov spring wasn't strong enough.

0\s accord
08-05-2011, 02:09 PM
haha whats your deff in strange.....and i should be getting the factory up pipe sometime the this weekend.... what wastegate would u get...i dont want to go back to another agp wastegate

0\s accord
08-06-2011, 09:50 AM
ok i let two ppl ride with me last night and both of them said my bov siezed up... which does make since why it shutter cause the turbo is backspinning and making the shuttering noise out the intake... just wanted to get yals opinion on that...

onebadgt
08-06-2011, 05:01 PM
sounds like a logical awnser to me, like i said i had a number of issues with my rs, i just bought it because i thought it looked cool, but the hks ssq is a FAR better bov with a much stiffer spring.

0\s accord
08-18-2011, 10:51 PM
so it was my BOV that took a shit...thanks everyone for the help!